Possible reasons for passwordless emails not arriving to a company's corporate outlook accounts?

Hello,

We’ve implemented Auth0 into our systems and it mostly works fine - both our outlook and gmail accounts receive their emails consistently and fine with Sendgrid.

However, one of our clients seems to be unable to receive our passwordless emails. Sendgrid states they are delivered, we’ve tried turning SendGrid off as well but it makes no difference. They arrive neither to the spambox nor inbox of any employees within their email domain.

They use Outlook and haven’t got an IT department it seems, so there shouldn’t be any arcane configs going on beyond defaults.

Now, we intend to find out what we can but obviously there’s many different companies out there with many different email domains. What are some reasons why the code emails would fail to arrive to accounts within a company?

Our personal emails arrive just fine with them, so we know our domain isn’t blocked, at least… We’ve set all the correct DKIM and SPF records as well.

1 Like

Hey there!

Let me discuss it internally what might be the potential reason behind it

1 Like

So one of the things our developer support team suggested is that if Sendgrid says they have been delivered and you guys are using Outlook:

  1. it is either in your spamfolder (which isn’t true as you’ve said)
  2. if your are using Office365, the email may have been quarantined https://docs.microsoft.com/en-us/microsoft-365/security/office-365-security/quarantine-email-messages

Hey there have you had a chance to check that?

HI Konrad,

We experience this with multiple different outlook accounts. They are using the quarantine feature but are still unable to get emails. What can we do to minimize this? Can we chat offline?

Thanks,
Phil

Hey there @philrees!

As far as I discussed that this is the only guidance we have on this front

Hi Konrad!

Any update on this? We are facing exactly same problems. We have tried both Mailgun and Sendgrid with DKIM and SPF records set but somehow emails to outlook using customers just vanish. This happens with multiple customers.

Unfortunately I didn’t receive any other guidance on that front from the engineering team.