Passwordless Connections - Email cannot be activated in dashboard!

I am running vanilla chrome, logged into my auth0 via github.
I went to Authentication > Passwordless > Passwordless Connections.
I unchecked Email to debug something. – It worked.

Then I wanted to re-check it.
DOESN’T WORK. Cannot re-enable email. I restarted the browser, logged out and relogged in. Nothing.

Browser console says this when I click the Email checkbutton:

Hi @apd,

Thanks for reaching out to the Auth0 Community!

Could you please try using the Management API v2 Update a Connection endpoint to enable your Passwordless Email connection?

You will need to specify the enabled_clients property with your list of client_id’s to enable the connection. Here is a sample body:

  "enabled_clients": [

Please let me know how this works for you.

Thank you.

Ok… So in the “body” I write what you said, with my client id, but what do I write in the “id” field? “The id of the connection to retrieve”? - what’s that for this command? “passwordless email”?

Ok I figured it out. Here’s how.
THIS SHOULD BE DUCTTAPED TO THE EMAIL CHECKBOX… seeing as how it’s the only way to “use” that button.

Step 1: Go here: and copy your Token:

Step 2: Go here: and “SET API TOKEN”, paste the token there. Then click on “Try” to “Get all connections”. Just leave all the fields in the form blank; you won’t have that many connections. This will list a json with all the types of login providers you have for your app. In my case it was Email, Google OAuth, and Microsoft. Copy the “id” for the json part that describes the “email” strategy.

Step 3: Go here: Auth0 Management API v2 and again SET API TOKEN. Then in the “id” field of the form, paste the id you just copied in step 2. In the form’s body, paste what rueben wrote: {“enabled_clients”: [ … , … ]}, where inside the [… , … ] you paste all the Client IDs for your applications that you want to use (passwordless) email. You get those client ids from this page:

Thanks and please ducttape this guide to the email checkbox that does nothing. Or better yet, fix the checkbox.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.