Auth0 Home Blog Docs

Passwordless - no connections enabled for client

I’m having difficulty logging in with the passwordless email login, on 1 of my 3 tenants. The email connection is enabled for the client. I have no idea what the issue is and I’ve been trying for 2 days now. Thank you!

{
“date”: “2020-02-07T04:14:00.937Z”,
“type”: “f”,
“description”: “no connections enabled for the client”,
“connection”: “email”,
“connection_id”: “con_Mxx”,
“client_id”: “wxx”,
“client_name”: “My App”,
“ip”: “9xx”,
“user_agent”: “Chrome 80.0.3987 / Mac OS X 10.15.2”,
“details”: {
“body”: {},
“qs”: {
“scope”: “openid”,
“response_type”: “token”,
“redirect_uri”: “http://localhost:3000/callback”,
“verification_code”: “223154”,
“connection”: “email”,
“client_id”: “wxx”,
“email”: “dxx@gmail.com
},
“connection”: “email”,
“error”: {
“message”: “no connections enabled for the client”,
“oauthError”: “no connections enabled for the client”,
“type”: “invalid_request”,
“uri”: null
},
“session_id”: “oxx”
},
“hostname”: “auths.xx.com”,
“audience”: “https://xx.auth0.com/userinfo”,
“scope”: [
“openid”
],
“log_id”: “9xx”,
“_id”: “90xx”,
“isMobile”: false
}

1 Like

@ink I’m sure you already tried but doesn’t hurt to confirm, have you tried disabling it and re-enabling the connection again for that client? Also if you do a GET on /connection/:connectionid do you see the clinet id in the enabled_clients array? If this doesn’t give you any clue please DM me your non-working & working tenant names and client/connection names to investigate.

I have tried that. here is the response from /api/v2/connections/con_Mxx (it appears all of my clients are enabled)

{
“id”: “con_Mxx”,
“options”: {
“disable_signup”: false,
“name”: “email”,
“email”: {
“syntax”: “liquid”,
“from”: “{{ application.name }} root@auth0.com”,
“subject”: “Welcome to {{ application.name }}”,
“body”: “xxx”
},
“authParams”: “”,
“totp”: {
“time_step”: 180,
“length”: 6
},
“brute_force_protection”: true
},
“strategy”: “email”,
“name”: “email”,
“is_domain_connection”: false,
“enabled_clients”: [
“Mxx”,
“jxx”,
“vxx”,
“wxxT”
],
“realms”: [
“email”
]
}

If anyone would like to take a look into this I could message the details.