Password Reset Redirect not working

Hi,

I’ve been reviewing a few past posts, here:




I particularly appreciated Dan Woda’s flow chart.

I am using the new Universal Login, I have my Application Login URI set and I have also got the redirect_to in the reset email client set (although according to Dan’s flowchart this isn’t necessary).

I am still faced with the following:

I’ve tried multiple configurations and I’m not sure what I’m missing.

All help gratefully received :slight_smile:

Best,
Kevin.

Hi @dolearning,

Welcome to the Community!

Are you using the change password endpoint or requesting the reset from an application login page?

Hi Dan,

I’m doing this through the application login page:

This is the requesting password workflow:

This is the reset with no redirect or link:

Thanks,
Kevin.

Could you DM me a HAR recording of those transactions?

Thanks for addressing this topic. I was looking for the information regarding the same. Keep sharing the info, kudos.

No worries - I’ve sent my HAR to Dan, so I’ll shout out here if he resolves it.

@dolearning,

It doesn’t look like you are using the new UL. Try adding a Redirect To in your email settings.

Hi Dan,

I do have redirect to in my email settings already.

Thanks,
Kevin.

Have you set up an email provider yet?

No - I’m using the Auth0 emails - do we need to have a 3rd party email provider to get this to work? I’m not sure I saw that in the docs but if that’s the case, then great!

You should set up a third party provider regardless. I am using the dev provider (the built in one) and it seems to be working for me, but email customization isn’t supported by the dev provider, so it could be causing the issue.

Hi Dan,

I’ve set up a 3rd party email provider, as you suggested, but I still am not able to redirect after the password has been reset.

The application is launched at https://app.electrictogether.com to see it deployed.

I’d love your input and help.

Thanks,
Kevin.

Hi Kevin, I’m having the same exact issue you described. Did you ever figure it out?

Thanks

-Gary

Hey @dolearning fancy meeting you here :wink: did you manage to get to the bottom of this despite the thread going cold?

I have exactly the same issue and am also using 3rd party email provider etc.

Cheers

Hey! Good to see you!

The last response i had from @dan.woda back in December was this:

I tried this on my paid account, and it seems to be working, but if I try on a free account then it doesn’t save the redirect to, but only for the password reset page, the email verification works fine. This sounds like a bug. I’ll report it and let you know what I hear back.

Haven’t chased it up since then.

Aha thanks @dolearning

I have been testing on a free tier tenant to sandbox experimentation from a client’s subscription. I seem to spend way more time than seems reasonable snared up on these kind of minor snags in Auth0 trawling through documentation and community threads!

Cheers

P.S. I attempted to quickly verify on the paid subscription (very carefully!) but unfortunately got a different error which looks configuration related and can’t justify spending any more time on this right now. I’ll endeavour to confirm later and post back.

1 Like