Redirect in Change Password Ticket Not Working

I have reviewed this thread and have a similar case but oddly not working: Redirect / result_url in change password ticket not working

My setup has the New Universal Login Experience. I see that when using that supplying the result_url parameter does nothing. I see from the link above that you have to supply a value in the “Application Login URI” field in the application settings and that doing so should lead to the creation of a button/link that initiates the login experience.

When I first attempted this password reset my Application Login URI field was empty and I received the success message and nothing else, no redirect. After searching this problem and finding/reviewing this documentation I have completed the Application Login URI field in the admin panel (with the pattern https://mydomain.com/login.php). Now when I complete a password reset I still see the success check mark “Your password has been changed successfully.” and nothing else.

I was led to believe that I would see a button or a link that would take the user back to my app’s login page but I see nothing.

Just to confirm/reiterate:

  • New Universal Login Experience
  • Application Login URI has been completed with the pattern https://mydomain.com/login.php
  • After a successful password change I see a success message but no button to redirect the user back to my application.

What am I missing/doing wrong?

1 Like

How are you requesting the password reset? From what you provided you may be obtaining the ticket URL directly through the Management API; if you are I would suggest for you to try to use the following endpoint (https://auth0.com/docs/api/authentication#change-password) and ensuring you pass the client identifier of the application you updated to have the application login URI. If you already tried this and the outcome persists then some additional information will be required and ideally an HAR file showing both the request for password reset and the completion, but sharing that in a public forum has its considerations so we can cross that bridge when we get there.

I have a similar problem. I am using Lock v11 for authentication. I have also provided default login URI in the application as well as tenant levels. When I complete a password reset I still see the success check mark “Your password has been changed successfully.” and nothing else, especially no button, but when I provided redirect URL in the Emails template, the page is redirected to my login page after successful resetting of password (no button shown, just automatic redirect happens). What am I doing wrong? Please help me with this problem.

I believe the Lock 11 is the ‘New Experience’, and not the Classic Experience.

If you’re using Lock (11) then this would not be the new universal login experience. Have in mind that in order to use the new experience you have to both:

  • select the new experience in the universal login general section;
  • ensure that you do not have a customized login page as that will take precedence and force the use of the classic experience.

I can confirm that the redirect isn’t working, unless I’m doing something wrong. I have tried using the new login experience, as well as a custom login page.

1 Like

I wrote an FAQ to help address this common issue. Hopefully this will help future users:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.