Last Updated: Jan 8, 2025
Overview
According to the Customize New Universal Login Text Prompts under the reset-password header, a Back to My App button should be displayed when a user successfully changes their password. However, users do not see this button after successfully changing their passwords. This article explains why the button does not display.
Applies To
- New Universal Login
- Reset Password
- Back to My App
Cause
This button is only rendered when a default login route is configured.
Solution
Follow the steps or video below.
The ‘back to application’ button will only show when:
- The new Universal Login experience is enabled
- The password reset page HTML has not been customized. Customizing it directly (i.e., NOT using page templates or one of the New ULP customization APIs) causes the password reset page to revert to the Classic Universal Login experience.
- A tenant and/or application default login route has been configured. Refer to Configure Default Login Routes and Password Reset
The button will show after a successful password reset if these requirements are met. It should know the relevant clientID/application based on the reset ticket the Universal Login widget generated automatically.
NOTE: If the ticket is generated by calling the change password endpoint directly, make sure to include the client_id parameter for Auth0 to use the application’s default login URI. Otherwise, Auth0 will fall back to using the tenant default login route.
See this article that explains the Password Change Redirect Behavior in detail: Password Change Redirect Behavior