No Back to Application Button after Changing Password Successfully

Last Updated: Sept 25, 2024

Overview

According to the Customize New Universal Login Text Prompts and specifically the section “reset-password”, a button 'Back to My App ’ should be displayed when a user successfully changes their password. However, users do not see this 'Back to My App" button after changing their passwords successfully. Why is this button not displayed?

Symptoms

No button is rendered to take the user back to the application after successfully changing their password.

Cause

This button is only rendered when a default login route is configured.

Solution

Follow the steps or video below.

The ‘back to application’ button will only show when:

  1. The new Universal Login experience is enabled
  2. The password reset page HTML has not been customized. Customizing it directly (i.e., NOT using page templates or one of the New ULP customization APIs) causes the password reset page to revert to the Classic Universal Login experience.
  3. A tenant and/or application default login route has been configured. Refer to Configure Default Login Routes and Password Reset

The button will show after a successful password reset if these requirements are met. It should know the relevant clientID/application based on the reset ticket the Universal Login widget generated automatically.