MFA Enrollment Fails with Maximum Authenticators Error

Overview

This article explains why the following error occurs when a user attempts to enroll in Multi-Factor Authentication (MFA):

Guardian - User has created the maximum amount of authenticators

Applies To

  • MFA enrollment

Cause

This error occurs when a user fails to complete MFA enrollment multiple times. After 50 failed attempts, the user is blocked from enrolling a new authenticator.

Solution

To resolve this issue, use one of the following options:

  1. Perform an MFA reset for the user.
  2. If the MFA reset does not work, execute a DELETE call to the Management API endpoint to delete the user’s authenticators.
  3. Alternatively, wait 24 hours. Pending authenticators have a 24-hour Time To Live (TTL) and are automatically removed if they are not confirmed. After this period, the user can attempt MFA enrollment again.