Localize page after email is verified

Hi all!
I’m trying to localize the webpage displayed after the e-mail address is confirmed.

I’ve just added the ui_locales param to the verification URL in the email template.
I noticed that the url in the email looks like this https://api.mydomain.com/u/email-verification?ticket=<ticket id>&ui_locales=es, but the destination page which url looks like https://api.mydomain.com/lo/verify_email?ticket=<ticket id>, doesn’t.

Is there a way to localized it?

Hi @gimena ,

The pages shown outside of the normal login flow currently rely upon the Accept-Language header being sent by the user’s browser and matching one of the languages enabled in your tenant’s settings.

You may find this thread useful for some alternatives to ensure a certain locale is used per your criteria:

In particular this part for modifying the generated URL in the verification email.

Hi @sgo thanks for your response,

I’ve checked the link you shared and tested adding the ui_locales=ja param to the url but it’s not working (ja is enabled for tenant). When I click the link, although it has the ui_locales setted, the resultant page is still displaying in english. If I click the link again, the page displays translated.
Is there something that I’m missing?