Auth0 Home Blog Docs

LinkedIn connection InternalOAuthError

oauth
error
linkedin
invalid
connection

#1

Affecting all tenants. Confirmed by using “TRY” button on Connections > Social screen.

Snippet from logs:

"connection": "linkedin",
  "error": {
    "message": "InternalOAuthError: failed to fetch user profile (status: 500 data: {\n  \"errorCode\": 0,\n  \"message\": \"Internal API server error\",\n  \"requestId\": \"9DE8Y9WQD9\",\n  \"status\": 500,\n  \"timestamp\": 1516184195813\n})",
    "oauthError": "invalid_request",
    "type": "request-error"
  }

#2

Same here, seems like sign-in works for some of our users.
We haven’t deployed to staging/prod in the past month, and neither of our environments works at the moment (we’re using two separate tenants).

Any idea on when are you planning to handle that, so we can adjust comms with our users?


#3

Same here, seems like sign-in works for some of our users.
We haven’t deployed to staging/prod in the past month, and neither of our environments works at the moment (we’re using two separate tenants).

Any idea on when are you planning to handle that, so we can adjust comms with our users?


#4

This is being caused by a glitch in LinkedIn’s API that happened in the last 24 hours. To our current Knowledge, LinkedIn has not officially acknowledged this or responded whether they will be fixing this soon.

In the meanwhile, our engineers are working on a temporary workaround that will cause the logins to work (despite LinkedIn API issues).

You can find more information in our status page.

Edit: The workaround is now in Preview. You can find the environment your account is on through the Support Center. It should reach the stable environment tomorrow. If your account is on Stable and you need to have the workaround today, you can open a Support Ticket and we can move you to Preview.


#5

Thanks @anny - I notice however that http://status.auth0.com/ is not updated with this information?


#6

Not sure if that helps, but it seems to be related with the current-share field.

Related issue (and a potential workaround) on GH/passport: https://github.com/auth0/passport-linkedin-oauth2/issues/24


#7

Hi! I checked internally and we are going to post to the status page soon


#8

http://status.auth0.com/incidents/6xtmprjjt9cb


#9

Agreed that it’s related and a good workaround, but such parameter cannot be set through Lock.


#10

Your engineers have done it: it works again.


#11

yes working for us. @anny pass on thanks to the engineers!


#12

Great that you fixed it, but the problem seems to also be affecting your OSS library : https://github.com/auth0/passport-linkedin-oauth2

Could you perhaps publish the code changes for the fix so that we can at least workaround the issue while using this library? Thanks!


#13

passport-linkedin-oauth2 has its own answer you can read at the bottom of https://github.com/auth0/passport-linkedin-oauth2/issues/24


#14

The OSS library has not been updated as this is an issue with LinkedIn that they will need to fix in their API. There is a fork of the OSS library which has the temporary workaround (https://github.com/mcastany/passport-linkedin-oauth2 in the “remove-current-share” branch).

An alternative is not to use the r_basicprofile scope and write down the list of scopes you need as a workaround (to use a released version).


#15

Great thanks guys!


#16

According to LI on twitter, this issue has been fixed - https://twitter.com/LinkedInHelp/status/954354615230885888

I am not too sure though, I’ve used the workaround to get around it, and the auth0 status page still reports the problem. Anyone else still seeing this issue?