Overview
A user was taken to a team other than their company’s team when they logged in. They created two user accounts with the same email—one with an email/password and one with a Google social connection, which is expected behavior. The user preferred to sign in with Google. The user asked if it is possible to switch their account email/password, which was a team owner of their company’s tenants, with the user accidentally created with a Google social connection.
Applies To
- Team Management
Cause
The user accidentally signed in with Google Social Connection instead of email/password, not understanding it would create a different Auth0 user even with the same email address. They preferred to sign in with Google instead of email/password.
Solution
This is possible in lots of small and simple steps.
Delete the tenant ({tenant_name}) created using the Google account. However, that user will still be a part of the team with that tenant. Tenants can be deleted, but Teams cannot. If it is not desired for the Google account user to be associated with that team, create another account and add them to the team as a Team Owner. Then, remove the user with the Google account from that Team.
It is possible to associate the Google account with the tenants {tenant_names}. The steps are outlined below.
Ensure to be signed in through the company’s team using email/password before completing the following steps. Invite a new team member by following these steps:
- On the left side of the Teams Dashboard, select Members.
- To invite a new Team Owner, select Invite a Member.
- Enter the email address of the member to invite and select the access level ({email} and {access_level}, respectively).
- Select Send Invite.
- Go to the email and copy the invitation link (do not click the link).
- Open an incognito window and paste the invitation in the address bar.
- Sign in using the Google connection.
- You are now a Team Owner of the company’s team.
Alternatively, follow the steps listed in this documentation here.
Invite the Google account to be a member of the tenants in the team as well. Invite a new tenant member by following these steps:
- On the left side of the Teams Dashboard, select Members.
- Click the user account associated with Google.
- Click Add Tenant Access.
- On the Add Tenant Access screen, select one of the company’s tenants and select the roles that should be assigned to them (Admin and Elevated Support Access).
- Click Assign.
- Repeat this steps 3 - 5 for the other company tenant.
- You are now an Admin for both of your company’s tenants.
To remove the user associated with the email/password from the company’s tenant, follow the steps listed in our documentation here.