Tenant Created by Mistake - How to Delete a Tenant in the Context of Teams

Overview

A tenant was created by mistake when signing in and being prompted to create a tenant. This has also created a Team associated with it.

Applies To

  • Tenant Creation
  • Delete Teams
  • Delete Tenant

Cause

Auth0 prompts members to create a new tenant when:

  • They do not have any tenants associated with their account;
  • If they are part of some tenants with a Team, that Tenant Member Management enabled for it, and they are not at least a Team Contributor on that Team.

Solution

To get rid of unwanted tenants, head over to every tenant created by mistake and delete those tenants.
Fnd the tenant Delete button in Tenant Dashboard > Settings > Advanced and then scroll all the way down to the Danger Zone .

Creating a new tenant by mistake might also bring a new Team together with it.

  • Check all the Teams by heading over to https://accounts.auth0.com/.

  • If there are any unwanted Teams that do not have any tenants or other members associated with them, there might be an inclination to remove those so that they do not land on one of those Teams by mistake. Unfortunately, we currently do not support deleting or removing Teams. The only way to get rid of one is by asking someone else from the Team to remove the account as a member. If the account is also the only Team member, then invite another throwaway account as a member and then remove the main account with that throwaway account.

    1. To remove a member from a Team, search for the member in the Members list.
    2. Select the three-dot menu option and click on the Remove Member option.