How can implement the swissID login?

Now I am developing the authentication with swissID login.
SwissID is providing from swissID team.
In order to implement the I have used the custom social login.
I contacted to swissID team and received Client ID, Key and also other information.
Anyway, I just getting the 400error.
I think this is similar to login function like dropbox, slack login.

If someone help me, I will be very appreciate.

@enjoylifethemost123 can you please provide more information, such as the errors you see in the tenant logs (please remove any sensitive information before posting it here)?

You will need to ensure that you have correctly setup all the required settings in the connection, such as the Authorization URL, Token URL, Fetch User Profile Script, etc.

I am referencing this link

It’s about swissID login.

@enjoylifethemost123 The problem you are experiencing is likely to be with the configuration at the SwissID end, although you should check the configuration you have in Auth0 for Token URL Is be set to: https://login.int.swissid.ch:443/idp/oauth2/access_token. Contact SwissID and confirm the following with their team:

1: The redirect URI they have for your configuration is set as https:///login/callback, (i.e. the same as the redirect_uri parameter shown in the URL that’s part of the SwissID “400 Technical error”.

2: Confirm that they have set the configuration at their end to use client secret in the body of POST requests to their access token endpoint (i.e. https://login.int.swissid.ch:443/idp/oauth2/access_token). If you mention to them that you are using Auth0 they should know what needs to be done.

Hope that helps :slight_smile:

Thank you @peter.fernandez
I have tested with it Postman OAuth2.

So now I can get the access token and id token.

The problem is to implement the Auth0.

My registered URL is localhost:8080;

I have uploaded my Postman screenshot


I think this is because of redirect_uri. So I wanting to set the redirect_uri but couldn’t find the way to do it.

So do I have to register the url which is come from Auth0?

Or possible to set the redirect_uri?

Hi @enjoylifethemost123 :sunglasses:

That is correct: as I mentioned in my previous response, to use Auth0 the redirect URI SwissID have defined for your configuration must be set the same as the redirect_uri parameter shown in the URL you were getting as part of your SwissID “400 Technical error”.

Use of a verifiable redirect is a fundamental aspect of authorization server security, and simply being able to set or change this outside of the authorization server context would violate that security principal. So you will need to contact SwissID in order to make this change for you.

Hope that helps :slightly_smiling_face: