Auth0 Home Blog Docs

Access_denied error on User Logins

auth0
error

#1

Whenever I try to log into my auth0 application I get the following access_denied error :

{
“error”: “access_denied”,
“error_description”: “Invalid response code from the auth0-sandbox: HTTP 400. Unexpected token }”
}

I followed the instructions to connect my app to google but when I go Dashboard > Connections > Social to Try the connection I get the same error.

I had logins and authentication working on a local SPA pretty recently. I don’t know what changed to cause this error.

Any help or advice would be greatly appreciated.


#2

:wave: @EvanM did you already have the Google connection working and then it stopped? Have you changed any settings recently or added a Rule or Hook? We’ve seen this happen when a Rule or Hook is interfering. Or is this a new connection you are creating?


#3

I was recently playing around with a new rule. I just deleted it and I’m no longer getting that error when I test the Google Connection!

Thanks Kim! I’ve been wrestling with that for a week. You’re a life saver.


#4

For me the rule was added by team member that wasn’t functional and it had a global variable. Moving the variable in the rule function fixed it.