Auth0 Home Blog Docs

Login with Auth0 account (db connection) Unable to issue redirect for OAuth 2.0 transaction but redirect_uri provided


#1

We have a setup with a few social connection and database connection.
While all social connections work fine when we try to sign up with login and password (database connection) we get login error and find this in Auth0 logs:
Unable to issue redirect for OAuth 2.0 transaction

I searched for possible reasons and in most cases the reason for this issue was that redirect_uri is not provided.
However in our case redirect_uri is set and also reported in the same log entry so I’m sure it’s reaching Auth0.


#3

Hey there @sebastian.belczyk when you get a moment can you snag us a HAR file while replicating the issue and DM It over to me. This will allow us to see better troubleshoot the challenge you are experiencing. Thanks!


#4

See attached HAR files. These are for registration (user is created during registration but not redirected back to our site) and for login.


#5

Thank you for the HAR files. I will review them and see what I can find with our team.


#6

I see from the login.har file that there is a 500 error in your POST from the callback. Can you share a sample of your code so we can take a looking at your redirectUri? Thanks in advance!


#7

I wanted to follow up @sebastian.belczyk and see if you are still experiencing the previous issue referenced? If so, can you share a sample of your code so we can take a look at your redirectUri? Thanks.


#8

I was trying find the problem causing 500 on our side and apparently it’s not occurring anymore. We must have fix it in the mean time. It is strange because even before I didn’t see any exceptions or suspicious log entries on our side but anyway thank you for your help, it works now as expected.


#9

I’m glad to hear everything worked out! Please let us know in the future if you have any additional question!