Failed to accept administrator invitation

I have a email with invitation to be a tenant administrator.
When I try to accept this invitation (by button, or by link) I see a message


Looks like something went wrong!

We track these errors automatically, but if the problem persists feel free to contact us. In the meantime, try again.

Contact Support

The same situation after logging in.
Looks like this issue is similar to this one


Have you tried to accept this invite in an incognito window? The links expire after 24 hours, were you trying after this period?


Hey, karen1!
Actually I made 2 attempts (2 separate invitations).
The 1st one I try after 20h from invitation send, the second one just instantly. Both had no luck.
I didn’t try incognito mode, but I try with different browser

Can you try with the incognito mode to see how it behaves and let us know? Thanks!

Hey, konrad.sopala.
It works now. Thanks

1 Like

Perfect! ++ for @karen1!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.