Failed Social Login - Callback Error?


I have a strange problem regarding Google Social login (username-password combination works fine). When I try to login with google social login I just get the “Oops something went wrong” Screen.

In the console logs I see:

GET https://****…
which returns a 400 Bad request error.

I also created a new application and added its credentials but still same error.

The Auth0 Log says:
You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn’t find your session. Try logging in again from the application and if the problem persists please contact the administrator.

Hi @patrick12 ,

Welcome back to the Auth0 Community!

I understand that you are facing the error while using Google Social login.

I tested on my end and could not repeat the same.

Have you tried clear the browser cache and cookies, and also in Chrome Incognito mode?

If the error persists, please DM me the HAR files and we will check this further.

Thank you!

1 Like


yes I tried deleting cookies and incognito mode. All users experience the same issue with social login but only on this application, every other works fine.
I’ve sent you the Har file


Thank you for providing the Har file.

I checked your tenant and noticed that you are using Auth0 developer keys on your Google social connection. This maybe the cause of the error.

Would it be possible to get your own keys and test it out? This article explains the details.

Please keep us updated on how it goes. Thanks!