Auth0 Home Blog Docs

Errors when setting up Authorization Extensions

I am currently trialing Auth0, with the intention of using it to manage users, groups and permissions within a web app. I added the extension on the web portal, but have not been able to complete the configuration. I get access denied messages when I try to publish a rule. I then get the following error when attempting to authenticate using the MVC sample application.

"OpenIdConnectMessage.Error was not null, indicating an error. Error: ‘unauthorized’. Error_Description (may be empty): ‘Authorization Extension: Invalid API Key’. Error_Uri (may be empty): ‘’."

How do I get the rule published, and an API Key generated. See attached images for error details

Can you try logging out of the dashboard, close the extension’s tab and logging in again, and then try to publish the rule?

Hi ,

I have tried that. I have also tried uninstalling and reinstalling the extension, and that hasnt worked either.

Looks like the issue was with my S3 configuration. Now sorted. Thanks.

Glad you were able to make it work in the end!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.