Auth0 Home Blog Docs

Authorization Extension: Invalid API Key

When trying to login via an API to /oauth/ro we’re getting the following error response:

{
“error”: “unauthorized”,
“error_description”: “Authorization Extension: Invalid API Key”
}

I should add, this is causing our site to be down. No one can login.

Your expediency would be appreciated.

Thanks!

I am seeing the same happen with our Azure AD enterprise connection. It is blocking all logins.

Got it working - looks like Auth0 did something that messed it up, but here’s how we fixed it.

Goto your “Authorizations” section/extension.
In the upper right goto “Configurations”
Click “Publish Rule” to republish the rules.

Fixed it for us. Hope it fixes it for you.

3 Likes

That did the trick for us also. Thanks for letting me know.

1 Like

Event reported here: https://status.auth0.com/incidents/tz8yxxl63bh9

We were having the same problem. @jkelly-carsaver solution got us up and running again.

Note change in API key and change in webtask.io URL:

$ diff rule1.js rule2.js 
3c3
< *  Updated by mark.drummond@empire.ca, 2017-07-06T13:59:55.701Z
---
> *  Updated by mark.drummond@empire.ca, 2019-04-04T19:50:15.489Z
7c7
<   var EXTENSION_URL = "https://empirelife-prod.us.webtask.io/abc123";
---
>   var EXTENSION_URL = "https://empirelife-prod.us8.webtask.io/abc123";
46c46
<         "x-api-key": "API_KEY_1"
---
>         "x-api-key": "API_KEY_2"

Tagging some Auth0 folks: @konrad.sopala, @James.Morrison, @kim.maida.

Possibly related to the extensions page troubleshooting (https://status.auth0.com/incidents/7qk7dcbgtjy6) but that is just a guess. The change from us to us8 in the URL is related to the node.js 8 webtask.io environment vs. pre-node.js 8 webtask.io environment. Maybe something triggered existing authz extension environments to re-cycle and come up in the node 8 environment. Again, just spit-balling.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.