Auth0 Home Blog Docs

Erratic behaviour when enabling/disabling db connections

Hi everyone,

Here to report some weird behaviour I experienced today (that involved our prod being down, everyone panicked, but it s solved now, so all good)
One of our developer needed to create a new native app in our Auth0 tenant, he was not sure which database connection to enable for it, so he fiddled a bit with the buttons.

Problem that it seemed to have disabled all database connections for all our applications (!!!)
After re-enabled everything back on, I tried to reproduce what could have lead to this situation.

That’s what I ve found :

Let s say I have 1 database connection (Username-Password-Authentication), and 2 applications using it (1 native app, 1 single page app):

I go to the native app details, select the ‘connections’ tab, and want to disable the database connection:

When I go to the list of applications connected to the database connection, I observe that ALL the applications have been disabled, and not only the native app:

Seems that disabling the database connection on the page of one application disables it for all the applications connected to the database connection.

Is this expected behaviour of the dashboard? I dont believe that an action in the settings of 1 application should be reflected to all applications.

Please let me know if this is not clear, or if I missed something.

Hey there!

Thank you a lot for reporting that! It’s not how it’s supposed to behave. I’ll make sure to relay it to appropriate team! Really appreciate putting together all the context and screenshots!