Email Field is not passing with the Data from Auth0 to my application

Hi there, I’m trying to use Auth0 for my application which is a community on, but the circle is not able to receive email field from the Auth0.

I’m pasting below the lastest log details shared by circle’s support. please look into it and let me know how to fix this. This is extremely critical and urgent. We need to fix it asap.

Circle’s email:

Our development team was able to investigate this and accoridng to them this is happening because the body for the user_info response is blank {}. You would need to reach out to Auth0 support to figure this out. This is the response raw dump on the user info response:
“get_user_info_response”: {
“status”: 200,
“headers”: {
“date”: “Thu, 13 Apr 2023 17:10:35 GMT”,
“etag”: “W/"2-vyGp6PvFo4RvsFtPoIWeCReyIC8"”,
“vary”: “Origin, Accept-Encoding”,
“cf-ray”: “7b7552c51b030837-IAD”,
“server”: “cloudflare”,
“alt-svc”: “h3=":443"; ma=86400, h3-29=":443"; ma=86400”,
“connection”: “keep-alive”,
“set-cookie”: “did=s%3Av0%3A1ac3b160-da1e-11ed-908c-29636955086f.8xuzQnaiOb579zqgk2Lq3rPvV7oAlf7HcmtM1FIGF7A; Max-Age=31557600; Path=/; Expires=Fri, 12 Apr 2024 23:10:35 GMT; HttpOnly; Secure; SameSite=None, did_compat=s%3Av0%3A1ac3b160-da1e-11ed-908c-29636955086f.8xuzQnaiOb579zqgk2Lq3rPvV7oAlf7HcmtM1FIGF7A; Max-Age=31557600; Path=/; Expires=Fri, 12 Apr 2024 23:10:35 GMT; HttpOnly; Secure”,
“tracestate”: “auth0-request-id=22840a67e651d463c3da350691083170,auth0=true”,
“traceparent”: “00-22840a67e651d463c3da350691083170-1cce2fc268096ac1-01”,
“content-type”: “application/json; charset=utf-8”,
“cache-control”: “private, no-store, no-cache, must-revalidate, post-check=0, pre-check=0, no-transform”,
“content-length”: “2”,
“cf-cache-status”: “DYNAMIC”,
“ot-tracer-spanid”: “1cce2fc268096ac1”,
“ot-tracer-sampled”: “true”,
“ot-tracer-traceid”: “c3da350691083170”,
“x-auth0-requestid”: “243c0910aab07c7b15b1”,
“x-ratelimit-limit”: “10”,
“x-ratelimit-reset”: “1681405848”,
“x-ratelimit-remaining”: “9”,
“x-content-type-options”: “nosniff”,
“strict-transport-security”: “max-age=31536000”,
“access-control-allow-origin”: “*”,
“ot-baggage-auth0-request-id”: “22840a67e651d463c3da350691083170”,
“access-control-expose-headers”: “X-RateLimit-Limit, X-RateLimit-Remaining, X-RateLimit-Reset”,
“access-control-allow-credentials”: “false”
“raw_body”: “{}”

Hi @nawaz.akram,

Welcome to the Auth0 Community!

To investigate the issue further, would you mind providing me with the code and exact steps you took that led to the email field not being passed?

I look forward to your update.


1 Like

Hi @nawaz.akram,

I have not heard from you since your initial post.

Please reach out to us again if you have any issues.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.