Auth0 Home Blog Docs

Drop Box Enabled But not in Login Page



I have add Dropbox in to my application, generated the keys, and tested the integration from within the Dropbox API. This all works fine.

However, when I try to log in to my website, Dropbox does not appear as an option on the Auth0 logon screen.

I can see that Dropbox is in the list of strategies that are retrieved by the Auth0 logon page, however the button is simply not being rendered.

You can see the strategies retrieved here:

But no button is shown here:

But the test from the Auth0 UI works:

Has anybody encountered or resolved this? (Or just have any idea?)


Based on the information provided the only thing that comes to mind would be if you have configured Lock to not show all available connections. For example, that exact behavior of only showing Google while the Dropbox connection is also available could be achieved by configuring allowedConnections option with the Google connection only.

If the above is not the source of the issue then you should update your question with the Lock configuration you’re using as that may provide additional information to troubleshoot.


I am using the dotnet core implementation.

Here is my configuration:

        services.AddAuthentication(options =>
                options.DefaultAuthenticateScheme = CookieAuthenticationDefaults.AuthenticationScheme;
                options.DefaultSignInScheme = CookieAuthenticationDefaults.AuthenticationScheme;
                options.DefaultChallengeScheme = CookieAuthenticationDefaults.AuthenticationScheme;
            .AddOpenIdConnect("Auth0", options =>
                // Set the authority to your Auth0 domain
                options.Authority = $"https://{Configuration"Auth0:Domain"]}";

                // Configure the Auth0 Client ID and Client Secret
                options.ClientId = Configuration"Auth0:ClientId"];
                options.ClientSecret = Configuration"Auth0:ClientSecret"];

                // Set response type to code
                options.ResponseType = "code";

                // Configure the scope

                // Set the correct name claim type
                options.TokenValidationParameters = new TokenValidationParameters
                    NameClaimType = "name"

                // Set the callback path, so Auth0 will call back to http://localhost:5000/signin-auth0 
                // Also ensure that you have added the URL as an Allowed Callback URL in your Auth0 dashboard 
                options.CallbackPath = new PathString("/signin-auth0");

                // Configure the Claims Issuer to be Auth0
                options.ClaimsIssuer = "Auth0";
                options.SaveTokens = true;
                options.Events = new OpenIdConnectEvents
                    // handle the logout redirection 
                    OnRedirectToIdentityProviderForSignOut = (context) =>
                        var logoutUri = $"https://{Configuration"Auth0:Domain"]}/v2/logout?client_id={Configuration"Auth0:ClientId"]}";

                        var postLogoutUri = context.Properties.RedirectUri;
                        if (!string.IsNullOrEmpty(postLogoutUri))
                            if (postLogoutUri.StartsWith("/"))
                                // transform to absolute
                                var request = context.Request;
                                postLogoutUri = request.Scheme + "://" + request.Host + request.PathBase + postLogoutUri;
                            logoutUri += $"&returnTo={ Uri.EscapeDataString(postLogoutUri)}";

                        context.ProtocolMessage.SetParameter("audience", $"https://{Configuration"Auth0:Domain"]}/api/v2/");

                        return Task.CompletedTask;


I have posted my configuration here .