Continue with Enterprise button is visible in the login page without enabling this feature on the dashboard

Problem Statement

We have created multiple connections in my Auth0 tenant, one DB, and one enterprise. The enterprise connection has the “Display connection as a button” option unchecked.

We have also set up organizations and use the “Identifier First” or the “Identifier + password” experience. When trying to log in via organization, we can still see the “Continue with Enterprise” button. With the above configuration, we expect the connection buttons not to show up.

Steps to Reproduce:

  • create organization
  • enable at least one enterprise connection and don’t enable it to be shown as a button
  • log in via your organization and you’ll see the button for the enterprise connection

Solution

This use case is not currently supported. Please communicate your use case with our Product team via feedback.