SAML Enterprise Connection showing Connection Button when disabled

Hello,

I am using Auth0 Organizations and have a couple authentication connections the Organization is pointing to. One is a database, one is an Enterprise SAML connection. For the Enterprise SAML connection, I have “Connection button” disabled, but I am still seeing the button show up. It seems like I should be able to use Identifier First and let the user enter their email address and if Home Realm discovery matches the domain, use the SAML connection, otherwise use the database connection. I’m looking for help to find out of this is expected, or if maybe I have something configured incorrectly.

Thanks!