Client Credential is getting enabled for Authentication - enterprise- saml-application

Hi Team

When I am creating client credentials using management API it is enabling all Saml - (Authentication - enterprise- saml)-application by default. Can anyone explain to me why the behavior is so?

Hi @gsinha,

Can you please share an example of the request you are making and the resulting behavior? Once you do this I will test it on my end and confirm the behavior.


Hi Dan

I am just creating an Application

Go To Applications → Create Applications → Machine to Machine.

When I do that I see the application gets enabled for all the SAML
Authentication → Enterprise → SAML → Applications.

I am not sure why?

Thanks for the added info. It sounds like you are looking for the Enable Applications Connections setting. This will turn on all connections for a new application by default.

You can access this setting under Settings → Advanced → Enable Applications Connections.

Let me know if that resolves it for you. Thanks!

Hi @dan.woda

This information does help. Any reason why that flag was enabled by default? Is this a recommended setting?

Enabling it by default allows you to create an application and have all connections toggled on. If you don’t want that behavior, then you will want to turn the setting off. It’s recommended insofar as it is the default, but it can be turned off if you prefer the opposite behavior.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.