Cannot Update User's Email on "email" Connection User

Overview

The customer is attempting to update the email for a user in Dashboard, but getting an error:

response: {
"statusCode": 400,
"error": "Bad Request",
"message": "The specified new email already exists",
"errorCode": "auth0_idp_error"
}

Cause

Passwordless users cannot be created from the Auth0 Dashboard.

They can be created directly from the Management API if signup is disabled. In the Connection field, use email for passwordless users using an email address. More details can be found here.

Solution

Creating a user with the new email through the Management API will solve the issue.

Here is the API documentation for the POST /users endpoint.