Problem statement
After updating a user’s email, they are unable to log in with the new email, but the old email still works. The user has a linked account with a passwordless email account and database account.
Cause
When you change the email address of a user from the Auth0 Dashboard, it will only change the email from the Primary Connection. This user was attempting to log in with their database username/password account which did not have the email updated since it was the secondary connection.
Solution
In order to change the email address for the secondary connection, you will need to use the Management API, by calling the PATCH/api/v2/users/{id} endpoint. The Management API documentation specifies that if you are updating email of a secondary identity, you need to specify the connection property in the request:
https://auth0.com/docs/api/management/v2#!/Users/patch_users_by_id