Auth0 Home Blog Docs

BUG? "{{ tenant.friendly_name }}" blank in SMS messages

bug
sms
tenant

#1

I have my SMS messages set up to include {{ tenant.friendly_name }} in the text. In my tenant settings, I’ve set a name for the tenant. My messages should say “Use {code} to complete your login to {friendly name}.” (Where {code} is the 6-digit code.)

For some reason, the “friendly name” field becomes blank. If I got back to tenant settings, alter the friendly name and save, it re-appears. But then it goes blank again. I’m not sure what triggers that. I am changing hosted page settings.

In any case it seems to be a bug. Any help appreciated!


#2

Pretty sure this is a bug. Here are repro steps that work for me. Need to use SMS for 2FA. The default message should be fine:

  1. Change tenant name. (In tenant settings)
  2. Trigger SMS. Observe tenant name.
  3. Update a hosted page (for example, change the title of the Guardian Multifactor page).
  4. Trigger SMS. Observer tenant name is missing.
  5. Go to tenant name, click ‘save’ (w/o changing anything).
  6. Trigger SMS. Observe tenant name reappears in message.

#3

Hi @jbailey, yes, we got some other reports as well and could reproduce the problem. Sorry about this.

We will fix this soon, but as a temporary workaround can you hard-code the friendly name in the SMS template? (instead of the {{tenant.friendly_name}} tag)


#4

Update: this issue was fixed and will be deployed within next week