Auth0 Home Blog Docs

MFA-widget tenant name

Hi. I’m not able to find any documentation regarding this. But the issue I have is the following, when setting up an authenticator other than Auth0 Guardian, i.e. Google Authenticator or Lastpass, the tenantFriendlyName never seems to be used, so the new entry in the authenticator app will be displayed as the tenant name / id.

Now I have a requirement that this should be displayed as something other than the tenant name. So in the userData config, does the tenant property need to match the tenant id in Auth0 or could it be whatever? Or do we somehow need to rename our tenant in Auth0?

Thanks in advance!

Welcome to Auth0 Community! @tom.granerod :partying_face:

Can you please make sure to have this settings right:

  • Set the friendly name here. In addition, please make sure to click Save .

  • I would recommend if you haven’t already, configuring a paid Twilio account. I set the credentials on this page (https://manage.auth0.com/#/guardian) and it sends the friendly name set on the tenant via text. (Please let me know if you are using a paid Twilio account.)

If you’ve done it, can you please make sure to try again in an incognito window?

Hi Lily.

The friendly name is set and is used when enrolling using the Guardian app. However when using Google Authenticator or Lastpass when enrolling the tenant id is used and later displayed in that authenticator app.

By changing the following I’m able to get it to show as the expected name and it seems to work, but could it have any negative side effects when not using the “userData.tenant” value here or is it just used for display purposes?

userData: {
      userId: "{{ userData.userId }}",
      email: "{{ userData.email }}",
      friendlyUserId: "{{ userData.friendlyUserId }}",
      tenant: "{{ userData.tenantFriendlyName }}", // WAS tenant: "{{ userData.tenant }}"
      {% if userData.tenantFriendlyName %}
      tenantFriendlyName: "{{ userData.tenantFriendlyName }}"
      {% endif %}
    },

I tried Google and another third party authenticator and the Friendly Name from tenant settings was imported correctly.

As another workaround you could try updating the Universal Login Page’s Multi-factor Page in the Dashboard. Under the Universal Login tab in the Dashboard and then the Multi-factor Authentication tab you can find the config for the page in question.
You could edit the line:

tenant: “{ userData.tenant }”,

to include the name you’re looking for hardcoded like

tenant: “Rabbet”,

Normally, that line should be using the friendly name. Could you take a look at the above and see if that changes how the name is shown in the Authenticator? The above should update those that are already set up as well once they’ve authenticated again with MFA.