Universal Login Classic does not respect the tenant friendly name

Problem statement

I have a tenant friendly name setup, when I use MFA with OTP with Google Authenticator, the default tenant name shows up on Google Authenticator and the not the friendly name.

I’m using Universal Login Classic and have configured the tenant friendly name to come through as below in the customised MFA screen but it does not work.

userData: {
 userId: "{{ userData.userId }}",
 email: "{{ userData.email }}",
 friendlyUserId: "{{ userData.friendlyUserId }}",
 tenant: "{{ userData.tenantFriendlyName }}",
 {% if userData.tenantFriendlyName %}
  tenantFriendlyName: "{{ userData.tenantFriendlyName }}"
 {% endif %}

Steps to reproduce

  • Enable Classic UL
  • Switch on MFA with OTP as a factor.
  • Set a tenant friendly name on the tenant via Tenant Settings


This appears to be a limitation with the MFA widget and works as expected on Universal Login New Experience.


There is a workaround and that is to switch from Classic to the New Experience.

If the pages are customised then classic will still be used so the users will see no change on login but this switch will cause the tenant friendly name to come through.