Overview
This article explains a potential cause for Branding customizations being ignored on the Passkey Enrollment screen but reflected on other screens, like the login screen.
Screen: passkey-enrollment
Applies To
- Branding
- Passkey
Cause
This is a known issue on some tenants that is being actively worked on by the Auth0 engineering team.
Steps to reproduce the issue:
- Create a new tenant
- Authentication > Authentication Profile > Select Identifier First > Select Save and Proceed.
- Authentication > Database > Username-Password-Authentication > Authentication Methods tab > Toggle on Passkey.
- Branding > Universal Login > Customize Company Logo and Primary Color and then Save.
- Sign up for a new user.
- Enter
email
and select Continue. /u/signup/passkeys
screen is displayed <— Branding is reflected.- Select Continue without passkey.
- Enter
password
and select Continue.
- Enter
- Login for the user.
- Enter
email
and select Continue. - Enter
password
and select Continue. /u/passkey-enrollment
screen is displayed <— Branding is NOT reflected.
- Enter
Solution
Page Templates can be used as a workaround until the root issue is resolved.
Follow these steps to customize a logo.
- Add the following lines within the tag of the html document in the Page Templates.
#custom-prompt-logo { background-image: url('https://{path_for_the_logo}.png'); }
- Update the Page Templates using Management API Set template for New Universal Login Experience endpoint: Set template for New Universal Login Experience
- Transition from the application to the login page with the custom domain. When logging in as a registered user, confirm that the logo is applied to the Passkey Enrollment screen.