Auth0 Home Blog Docs

Auth0 DNS issues with site hosted on Dreamhost?

oauth-wordpress-dns-

#1

Hi, I’ve been developing an app that authenticates an ASP.net Core application using Auth0 and an OAuth server plugin on a Wordpress website, so that users will have a common login between the Wordpress site and the ASP.net site. Everything was going fine for a few weeks, and I’ve used a couple of existing development Wordpress sites of mine hosted on Dreamhost as testbeds for the Wordpress side of things. However, midway through the day today, my logins started failing with the error:

{ "error": "invalid_request", "error_description": "Error: getaddrinfo ENOTFOUND designvirtual.pgcath.com designvirtual.pgcath.com:80" }

I’ve tried to connect to the sites manually, and they are accessible from the my machine and others on the Internet. I even setup an OAuth server at a different WordPress site (also hosted on Dreamhost), and got the same error. I’m curious what’s going on here, as nothing has seemingly changed on my end. It feels and seems like a DNS issue, but I’d like to be sure. Has anybody else had a problem like this, where Auth0 just stopped working for them in a similar scenario? I would like to find a resolution to this quickly, as it is blocking dev work on a project that I’m currently engaged in. Thanks in advance! Dan


#2

Well, my suspicions of this being DNS-related have been confirmed, as I left it alone overnight and it magically started working again today. Not wonderfully confidence-inspiring, but at least it’s a resolution. Just following up to close this thread out as it’s no longer relevant…

Dan


#3