Account Linking Extension with Organization

Do you guys know if the Account-Linking-Extension is working with the Organization structure?

Because after implement the Org it seems like the accounts aren’t merging anymore


Hey there!

Let me follow-up on that to make sure!

I need to ask you a couple of follow-up questions.

Can you get us some more details:

  • what is failing, at which step
  • tenant name
  • if you can reproduce: give us the date/time at which you reproduced and the behavior you saw that would help move this forward

Please send this information via private message here in the forum.

Thank you!

Was there ever a solution here? I may be running into the same issue.

I’ve installed the Account Link Extension (Account Link Extension), but it doesn’t appear to work for users with the same email. I am also using organizations. Not sure if that is the limiting factor.

We’re still trying to see if there’s a connection, as soon as I get any updates, I can share here.

1 Like

We’re still working on that. We’ll post the solution as soon as we get to it

1 Like

It seems like there’s a bug on our end and team acknowledged this. They added it to their backlog to implement the fix and go through further triage. I will let you know once the fix is deployed. Thank you @raphael2 for helping troubleshoot that!


Any new updates here?

Unfortunately still no information. Gonna reach out to the team again to see if they made any traction on this

Sounds good! Let me know what you hear. Thanks for keeping up with this!

I’m also experiencing issues with Account Linking and Organizations, the error message returned by the /authorize endpoint is:

the connection parameter is not supported with the organization prompt

This happens when clicking on “CONTINUE” in the Account Linking extension, which is supposed to prompt the user to login using a specific connection and in the context of an organization.

Is this the same issue?

Auth0 support is a disaster. 8 months later and I still have the same error. Disgusting.

Any updates ?

I have the same issue

@konrad.sopala Any updates on this issue. I just installed the extension today and still finding that if the user is already a member of a organization, their account is no longer merged.


We have run into several issues trying to use Organizations. This is the most recent one. If there was a better way to invite users to Auth0, we definitely wouldn’t use them, but unfortunately using Organizations is the easiest way to invite new users.

Still, it might be worth it at this point to implement our own invite flow because of the continued issues with Organizations.

Some context:

1 Like