Overview
This article explains why a 404 Not Found error may occur on the user/ssodata endpoint when using the Classic Login page with Lock.
Applies To
- Classic Login Page
- Lock
- /ssodata
Cause
The /user/ssodata endpoint was utilized by Lock to retrieve a user’s logged-in status from Classic Universal Login prior to the introduction of Seamless Single Sign-On (SSO). This endpoint is no longer in use when Seamless SSO is enabled and, as a result, returns a 404 Not Found error.
Solution
This behavior is expected. The 404 Not Found error does not indicate any issues, as the endpoint has been deprecated.
- Lock should no longer call this endpoint. However, it cannot be removed entirely because some older tenants do not use Seamless Single Sign-On (SSO).
See Upgrade reminder / changes to deprecation roadmap for more details about the endpoint depreciation.