Auth0 Home Blog Docs

GET https://<DOMAIN>/user/ssodata returns 404

Hi,

When I loginWithRedirect() I receive the following error:

GET https://<DOMAIN>/user/ssodata 404

The Dashboard guide states that you can toggle the Enable Seamless SSO option:

However, I can’t locate this option in the Dashboard:

Cheers
Rob

I personally find it unfortunate that the decision was for a 404, but technically the fact that the endpoint returns a 404 can be mostly ignore. The 404 means that for the particular tenant configuration and authentication request being performed that endpoint is not relevant so the server issues that response.

However, it should have no functional impact; if you’re experiencing a problem it probably will not be related to that so I would not treat that 404 as the smoking gun.

In addition, the setting you mention will only be available in older tenants which had access to a previous mode of SSO. For newer tenants seamless SSO is the default and already enabled, hence the lack of the setting.

I think that what you are describing is:

For all new Auth0 tenants (i.e., tenants created after <DATE>) seamless SSO is enabled and cannot be disabled. When signing in (for example, via the Authorization Code Flow with PKCE) you will receive a 404 from the following endpoint:

GET https://<DOMAIN>/user/ssodata

Although this error is unrelated to the standards-based activity you are trying to perform, you will receive this error whenever signing into Auth0.