"You may have pressed the back button" error using the Line connection

Problem statement

After configuring the Line Social Connection Marketplace Integration, when a user has authenticated with Line using iOS Safari, they are redirected back to the application with the following error message:

"You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn't find your session."

What is the reason behind this error, and how can it be resolved?

Symptoms

  • Line application installed on the device that started the login transaction.
  • Getting an error upon logging in with the Line connection on an iOS app.
  • Login works from a web browser when the Line app is not installed.

Steps to reproduce

  • Enable Line connection for an iOS app.
  • Install a Line application on the device.
  • Login through the app, and notice the error when redirected back from the Line app.

Cause

Line for iOS appears to be using iOS Universal Links:

Universal Links lets websites trigger specific apps in a secure way on iOS (via a signed file hosted on the web server). This contrasts with the more common custom URL schemes (which can be claimed by any installed app). Universal Links appear to be implemented only on Safari. Line uses them and thus gets triggered during normal login flows (i.e. after Auth0 redirects the user to the Line authorization server). This prevents login transactions from completing on iOS Safari.

Solution

This issue only occurs when the iOS device is attempting to use Safari to perform the Line Social Login AND the user has the Line app installed on their device. The issue will not appear if the iOS device in question uses a different browser such as Chrome to perform this login. Additionally, if the user does not have the Line app installed on their iOS device the issue will not surface and Line will simply prompt the user for their credentials.

As this issue involves multiple parties outside of Auth0, at this time there is no solution to accommodate users using iOS Safari with the Line app installed. This edge case is being tracked internally, however, please feel free to submit Product Feedback on the Auth0 Community Site to track interest in this issue so the Auth0 Product team can prioritize accordingly.

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