LINE Social Connection Not Working on iOS - Error "You may have pressed the back button"

Last Updated: Sep 26, 2024

Overview

When an end-user tries to log in to an application using iOS, Safari, or LINE Social Connection + LINE application, the following is observed:

  • Native Applications: The login/authorization sequence fails.
  • Web (SPA or Regular Web) Applications: A new window/tab is opened upon callback. The outcome depends on the SDK and its configuration.

Symptoms

  • For Native Applications
  1. The native application opens the Safari browser and displays the Universal Login page.
  2. The end-user taps the Continue with LINE button.
  3. The browser launches the LINE application.
  4. The end-user is authenticated within the LINE application, and then the LINE application opens a new browser window/tab. This window opened by the LINE application is different from the one the native application opened at the beginning of the login/authorization sequence.
  5. The Native application cannot handle the callback. The login sequence fails.
  6. When the user reopens the Universal Login page, the login sequence succeeds (because the browser has a session).
  • Web (SPA or Regular Web) Applications
  1. The web application opens the Safari browser and displays the Universal Login page.
  2. The end-user taps the Continue with LINE button.
  3. The browser launches the LINE application.
  4. The end-user is authenticated within the LINE application, and then the LINE application opens a new browser window/tab. The window opened by the LINE application is different from the one the web application opened at the beginning of the login/authorization sequence.
  5. With some SDKs / configurations, the user can log in to the application on the new window. Sometimes, the login sequence fails, and the tenant displays the error message:

You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn’t find your session. Try logging in again from the application and if the problem persists please contact the administrator.

To reproduce the issue

  1. Use Safari as a default browser.
  2. Clear History and Website Data.
  3. Install the LINE application.
  4. Enable the LINE Social Connection for an application and log in to the application.

Applies To

  • LINE Social Connection
  • LINE Application
  • Web and Native Applications

Cause

The LINE application has a feature named auto login. It will open the LINE application so end users can authenticate themselves without inputting credentials on the browser. However, the LINE application opens a new browser window/tab once its authentication process is complete.

This behavior prevents login transactions for a native application from completing.

Solution

  1. Use the disable_auto_login or disable_ios_auto_login option
    With the disable_auto_login/disable_ios_auto_login option, the client application can use the LINE Social Connection without launching the LINE application. The transaction will be completed within the same browser window. See Authenticating users and making authorization requests.
    Add the upstream_params option to the LINE social connection using Management API to pass this parameter to the LINE’s server.

    "options": {
        ....
      "upstream_params": {
        "disable_ios_auto_login": { "value": "true" }
      }
    }
    
  2. Change the default browser

    This issue only occurs when the user has the below combination:

    • iOS device
    • Safari
    • LINE application

    The issue will not appear if the iOS device in question uses a different browser, such as Chrome, to perform this login. Additionally, if the user does not have the Line app installed on their iOS device, the issue will not surface, and LINE (a web page) will simply prompt the user for their credentials.

    As this issue involves multiple parties outside of Auth0, at this time, there is no solution to accommodate end-users using iOS Safari with the LINE app installed. This edge case is being tracked internally, however please feel free to submit Product Feedback on the Auth0 Community Site to track interest in this issue so the Auth0 Product team can prioritize accordingly.

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