Auth0 Home Blog Docs

Yahoo connection not working

login
yahoo

#1

Hi I’m trying to set up the Yahoo social connection in my app, after following the guide exactly, chose contacts as the scope, and I get the following error when I use the test button in dashboard:

{
  "error": "access_denied",
  "error_description": "InternalOAuthError: Failed to obtain request token (status: 401 data: oauth_problem=consumer_key_rejected)"
}

There is no description of this error in the guide or anywhere online, I tried creating a new application with “profile” as the scope but that doesn’t work either. I also triple checked my consumer key and consumer secret to make sure i was copying the whole string.


#2

Hey there @anees!

Validating the token consists of a series of steps, and if any of these fails, then the request must be rejected. Here are the steps that API must perform to be able to successfully validate the token (these might be the potential reasons to look at)

  • Check that the JWT is well formed
  • Check the signature
  • Validate the standard claims
  • Check the Application permissions (scopes)

#3

I can request extra scopes but wouldn’t the dashboard’s “try” button handle all the other steps in token validation? I haven’t implemented this into my application yet because it failed when I used the “try” button.


#4

Hi, the same thing happened to me. I followed the guide exactly and after clicking the “Try” Button I received the same error message.:

“error_description”: “InternalOAuthError: Failed to obtain request token (status: 401 data: oauth_problem=consumer_key_rejected)”.

But I don’t know if I am on the right way, cause my aim is to recover the possibility to access yahoo api (https://query.yahooapis.com/v1/public/yql?q=…) that suddenly stopped to work 2 days ago. Is it a problem of authentication or yahoo stopped the service? Nobody reply to me. Thanks. E.


#6

Aaaa got it @anees didn’t know that you’re doing it with our online explorer. Yep the try button should handle all validation.

@coelotec , @anees let me get back to you once I discuss it with our developer support team!


#8

Hey @coelotec!

I think the reason behind it may also be coming from the Yahoo side. It will be advisable if you can also check with their community on how to potentially solve it.