Failed Yahoo login 405 error

I am trying to sign in using yahoo and I have done all of the appropriate steps but I keep getting the error below

{
“error”: “access_denied”,
“error_description”: “InternalOAuthError: Failed to obtain request token (status: 405 data: \n\n<meta http-equiv=“Content-Type” content=“text/html;charset=utf-8”/>\nError 405 HTTP method POST is not supported by this URL\n\n

HTTP ERROR 405

\n

Problem accessing /oauth/v2/get_request_token. Reason:\n

    HTTP method POST is not supported by this URL

<a href=“http://eclipse.org/jetty”>Powered by Jetty:// 9.4.z-SNAPSHOT
\n\n\n\n)”
}

I get this error everytime when I click “try” under social connections => yahoo.

Please help.

Thank you!

Hi @noakes1984,

Welcome to the Community!

I tested this and can confirm that behavior. Let me reach out to the appropriate team and I will update here with any responses.

Thanks,
Dan

This issue should be resolved.

Dan,

I appreciate the response.

I am still getting the same error when I click on “try” yahoo under social connection. I even signed out of auth0 and signed back in and still get the same error.

Thank you

Matthew

@noakes1984,

I misread the message about it. This will require a patch while it is resolved. Here are the instructions from the team:

“It looks like yahoo shutdown their oauth1 endpoints, so in the meantime while we fix this you can patch the yahoo connection options to use oauth2.”

{
"options":

{ .. other properties, "protocol": "oauth2" }

}

Dan,

Just to clarify. So does that mean when i go through the auth0 -> social connection -> yahoo -> “try” it won’t work but if I put these properties in the code of my project it should work?

Matthew

You should be able to use the ‘try’ function as well. I have tested it and confirmed it is working.

edit: Make sure you are adding your existing options to the patch request.

1 Like

Dan,

That did it! Thank you so much. One last favor! how do I get the access token that it generated so that I can make requests to the yahoo api for the users specific data not just its profile info (name, email, etc).

I am making requests to their api for fantasy football data and I need a token to do so.

Thanks again for the help.

Matthew

@noakes1984,

I have not done this, but I think the solution is to Add scopes/permissions to call Identity Provider’s APIs.

If this doesn’t work let me know and I can reach out to someone.

Thanks,
Dan

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.