Yahoo authentication

Hello -

Has anybody been able to get Yahoo to authenticate recently? When i read the documentation, it sounds as if I only need to copy over the client-id & client-secret issued by Yahoo to my Auth0 app, and of course, add to my Yahoo app. This is a very similar (almost identical) to dozens of other authentication methods.
Wwhen i click on “try” button on the “Social Connections” page, i get the following totally useless Yahoo error:

Uh oh

Looks like something went wrong.
Please try again later.

And when i try calling Yahoo from my Auth0 app, i get the same error, but only AFTER i enter my login information, and approve the app permissions.

Note that from doing further research on this, it appears this is a very common Yahoo problem and is most likely not an Auth0 issue but rather an internal Yahoo (read: Marissa Mayer) issue.

If this is indeed a Yahoo internal issue, i would question why Auth0 even has Yahoo as an option, if Yahoo is not supporting oauth2 anymore?

Hello! @edwardsmarkf

Have you saved the connection by clicking on the “Save” button next to the “Try” button, before trying the connection?

As a reminder, the “Try” button does not save the connection automatically.

Let us know if this helps!

1 Like

I am not seeing a “Save” button just a “Try” button, top right. Again, i do not believe this is an issue but rather an internal Yahoo issue, since i am prompted for yahoo email, password, and the permissions.


I am assuming that once i am prompted for permissions by Yahoo, everything is probably working correctly on the end.

Hi! have you tried clicking the Yahoo logo? it takes you to this Menu attached, there is where you configure the connection and you can save it before trying it. Maybe that helps!

first i set up yahoo:

then i clicked the Auth0 Yahoo social connection and copied the client-id and client secret over:

When i try it, i am prompted for a password, and then i am asked to approve everything (which i can only assume is everything is working with Auth0):

Then i see this error, which is most likely an internal Yahoo error since many applications are having the same issue.

so i am asking if somebody from Auth0 is able to log into yahoo successfully.

1 Like

I tried login in and I could, at first I had the same problem as you, but then, I started the process again, I hit “save” before trying it, and it let me. That’s why I thought it could be helpful.

  1. clicked “save”, see “Connection settins saved successfully” i the green bar:

then i click “Try”:

  1. now i click “Agree”:

  1. Uh oh…

1 Like

Hmmmm, it is really weird that you are still having trouble, it worked for me after having the same problem.

Have you checked if it is applying to any application? in the same menu but in the second tab, you can choose which applications you would like the connection to be applied.

yes, but i doubt it needs to be connected to an app before you can test it out.

i am wondering if its just something bizarre with my yahoo account. for fun. could you please delete your yahoo connection and create a new one?

from my research, this seems to be a pretty common issue, not only with oauth.

Hey! it seems it is an issue with Scopes, as you can see in here

Check this out, and maybe create a new client in yahoo and try the connection again with those details as a test.


1 Like

Thank you Karen Bermudez. it turns out i have not specified any scopes. wow how could i have possibly missed something so obvious? oh wait, maybe because it is not visible? thank you again, Marissa Mayer, for making Yahoo the outstanding company we can all be proud of.

quicky? i think the pony express moved faster than this:

EDIT: i found this on stack-overflow (below) - big clue that Yahoo is not displaying the API permissions. I HATE YAHOO…

UPDATE EDIT: Karen Bermudez’s comments gave me the idea of creating a new app and that one prompted me for the scope variables. but i still hate yahoo.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.