Auth0 Home Blog Docs

Infinite login screen loop with Yahoo

login
yahoo

#1

Hello,

today, while setting up yahoo, we ended up with an infinite login loop on Yahoo.

Even with a new account, and although we made sure to have the correct ID and Secret ID from Yahoo on Auth0.com, we were still blocked on the login page.

Our callback url on https://developer.yahoo.com/apps/ is the following one:
applicationname.eu.auth0.com

Anyone experiencing the same issue?

Thanks in advance,
Regards


#2

By correct ID, I meant,

Client ID (Consumer Key) and Client Secret (Consumer Secret).


#3

I am running into the same issue. I setup a completely new Yahoo application and connected it to Auth0. When I “test” it from Auth0 I asked to enter my Yahoo user id, which I do. It then sends me authentication on my phone and when I authenticate it, it sends right back to the Yahoo screen where I need to enter my Yahoo user id again. Yahoo seems to be stuck in a loop. Frustrating, I have been unable to find a fix for this.


#4

Hello,

I was able to reproduce this issue you are experiencing. We are currently aware of this issue and our engineering team is working to resolve it. I will update you all, once it is resolved.


#5

Auth0 Yahoo social connection is using OAuth1.0 flow and this seems to be broken on Yahoo end. Other people using Yahoo OAuth are reporting similar problems over the last few days: E.g.; https://twitter.com/buxfer/status/1029427896509591553

We have an alternative solution which uses OAuth2 flow. From the dashboard, it isn’t possible to set it but using the management API you could update.

I’ve outlined the steps below;

1- Using fetch all the connections API get all the connections and find the Yahoo from the returned list.

2- Patch the connection for Yahoo adding protocol:'oauth2' in the options object.

Make sure to copy the entire options attribute (the API only patches the first level, you need to set all the attributes inside options to avoid it to be overridden)

{
  "options": {
      "protocol": "oauth2",
      "client_id": "...", // replace with your app credentials
      "client_secret": "...",
      "profile": true,
      ... // any other attribute in options
    },
}

#6

I’ve tried this but are still having issues.

Now i get this error when i try to login from the website.

"Uh-oh!

Looks as if something went wrong.

Please try again later."

I can’t find any errors or anything in the network inspector and it doesn’t hit any of my rules or anything.

It seems to work better when i use the “try” feature in the dashboard however. At least they hit my rules and i get some errors from the rules. But from the website it doesn’t work. Hmmm … not sure what more i should include here.


#7

I managed to make it work now :slight_smile:

I had the wrong callback URL. It forced me to use my custom domain and i had the “regular auth0.com” domain.


#8

We’re glad you got it working! Let us know if you have any issues in the future!


#9

I’m having the same issue. I patched the connection no problem for Oauth2. But login to Yahoo fails. I have a custom domain that is in the redirect_uri. Is that not correct? I’ve sent a HAR file to support 5 days ago.


#10

I’m sorry to hear that Olaj. Upon investigating it appears you are currently working with one of our support engineers on resolving this matter. If any additional log information is available it can help when diagnosing these types of issues. Thanks!