Auth0 Home Blog Docs

WE'RE SORRY, SOMETHING WENT WRONG WHEN ATTEMPTING TO LOG IN.

the-generated-token-

#1

Trying to update to Lock 11 and use java-jwt 3.3.0 at backend. This is lock code

    var lock = new Auth0Lock('client-id', 'audience', {
      container : "auth0-root",
//      language : "sv",
//      redirectUrl : "/app/dashboard",
      theme : {
        logo : "/img/heart-115x115.png",
        primaryColor : "#00DBE5"
      },
      languageDictionary : {
        title : "Ladies First"
      },
      auth : {
        responseType : "token",
        redirect : !!deviceId // Login on same page (no popup)
      }
    });

When loading page, a warning shows in console:
There was an error fetching the SSO data. This could simply mean that there was a problem with the network. But, if a “Origin” error has been logged before this warning, please add “http://domain:port” to the “Allowed Web Origins” list in the Auth0 dashboard: https://manage.auth0.com/#/clients/client-id/settings

We have set the local domain and port for “Allowed Callback URLs”, “Allowed Web Origins”, “Allowed Origins (CORS)”
“Client Type” is “Regular Web Application”.
“Token Endpoint Authentication Method” is “Post”.

No error message appear at “authroization_error”:
lock.on(“authorization_error”, function(stuff) {
console.dir(stuff);
});

Auth0 logs shows (sometimes) “The generated token is too large. Try with more specific scopes.”


#2

We downgraded and it worked out fine.


#3

@swedishdate, can you please specify the version you’ve downgraded to so it worked for you?


#4

2.3.0

<!-- https://mvnrepository.com/artifact/com.auth0/java-jwt -->
<dependency>
  <groupId>com.auth0</groupId>
  <artifactId>java-jwt</artifactId>
  <version>2.3.0</version>
</dependency>