Auth0 Home Blog Docs

We want to hear your feedback about your experience using Auth0

Hi there everyone!

I’m Gino and work as a Product Manager for a newly formed working group here at Auth0 called Developer Productivity team. Our mission is to craft seamless delightful developer experiences by accelerating time to value and making identity simpler and we’re all about improving the way you use our product everyday to have you in production in no time!

We really want to hear your frustrations (and joys why not?) when using Auth0. Right now we’re focused on the onboarding, initial set up and dashboard experience as a whole (Error messages, navigation, terminology, etc.) but we’re open to hear your thoughts on any other experience as well.

There are two ways in which you can contribute:

  1. Leave a comment with your honest feedback on this topic :slight_smile:
  2. Book some time on our Calendar and we’ll be happy to have a quick 1:1 to hear you.

Calendar link: https://calendly.com/gino-cingolani

Your opinions count so much that we’ll use them to inform and build our future backlog! :scream_cat:

3 Likes

We’d love to know what you thought about your first experience with Auth0. Share your feedback so we can continue to improve the product and the experience for developers!

2 Likes

I find it unclear where to report bugs or suggestions besides the forums (as a non-paying user)

Hey there @tore!

You can use our product feedback site to contact directly our product managers with your feedback and context:

But its hard to find that page.

I would have liked to see a clear link to it on this page
https://support.auth0.com/

That’s the natual starting-place that I would go to submit feedback or bug-reports

3 Likes

Thank you for that feedback! I’ll relay it to appropriate team!

Hi @tore thanks for your feedback! I agree, having a direct access to our feedback page it’s definitely a good point. Any other thing you struggled with while implementing Auth0?

Yes, another annoyance is on the Applications -> Settings form and when you press “Save changes” you don’t see next to the button if the save was successful or not, because the message “The changes have been saved.” message is shown at the top of the page/form and not next to the save button.

So, my suggestion is to also show the success/error messages after pressing the save button next to the button. Today you can press save and you think all is well, when in reality there’s an error displayed at the top of the page that you can’t see unless you actively scroll up the page.

1 Like

Thank you so much @tore, we have this issue identified and we’ll be working soon on improving it! Let us know if you have any other comments.

I am grateful for Auth0 . The docs are very clear and beyond helpful. I was able to get started very quickly. I keep encountering an error that I’m certain is user error.
I plugged in pieces of the quickstart guide for the react-api and react-client implementation . I add the callback urls in setting. Sometimes it allows me to log in and sometimes I get an error message stating the Auth0 client cannot be found.

1 Like

I’m absolutely going to second this. The docs are amazing and very detailed. One small annoyance with them that crops up every now and then is following a link and ending up at a 404… But with every changing docs, I absolutely understand that’s very hard to fully prevent (and it does happen only every so rarely).

I really like the dashboard. It allows me to access pretty much everything I need to access very quickly. There are just two things that come to mind:

  1. When editing a user’s password, the dashboard doesn’t tell me if it’s compliant with the password policy for that connection. If it’s not, I don’t even get an error telling me that it’s not. It just does… nothing.
  2. You can’t link and unlink user accounts from the dashboard. That would help a lot with quick troubleshooting. Jumping to the management API isn’t the biggest hurdle, but I’d like to just press a button to link or unlink (I know, I’m spoilt).

Glad to hear this one is getting fixed. You wouldn’t believe how often I edit application metadata, only to assume it saved automatically (the UX does kind of suggest that) and then pull my hairs out for ten minutes trying to figure out why my rules don’t properly trigger for that application :sweat_smile:

1 Like

I am trying to get a working baseline NestJS + Angular app working with auth0. It’s really convenient that I see two tutorials with respective sample code posted by auth0 :

To summarize I just:

  • clone the sample apps,
  • replace the configuration to match my auth0 app / api settings (domain, audience, and client ID )
  • update the app settings to match the article in auth0

Unfortunately, I am still unable to get sample applications working. I am unable to even get the sample HTTP calls described in the article, working in Postman. It’s still quite possible that it’s an error on my part, but I can’t identify what I’ve done wrong.

I’m experiencing the following specific issues:

  • Auth0 complained about getting no response from localhost:3000. Consequently, I’ve ensured the API sample responds to GET on / root
  • The sample lists ‘audience’ as ‘localhost:3000’. This results in a “Service not found error” until I looked at my API settings and updated the audience value to https://[mydomain].auth0.com/api/v2/. I was able to login successfully once.
  • Post a seemed to be a successful auth0 login, now I am still seemingly unable to get a new token. Now the error message is ‘Login required’ Tracking 93846645bfdf6ba500cc
  • auth0 keeps complaining about getting a 404 on http://localhost:4200/api/items, but it responds fine locally. Maybe the path should be updated to make the request to port 3000? UPDATE: the Angular app makes bad calls to the Nest API app i.e. It has a bad endpoint.
  • logging out doesn’t actually work, since it doesn’t seem to make a call to auth0
  • CORS isn’t enabled for the nest API app
  • Just noticed an issue for Application Settings. http://localhost:4200 is not treated the same as localhost:4200. This behavior is the probably the cause of 90% of my issues.

Hey there @blee, thank you for your feedback. I see that you are experiencing a number of issues and I would be happy to assist on them. Below I have tried to answer them but moving forward a separate Community topic may be the best place to further troubleshoot them.

After confirming with one of our senior engineers, the first step would be to revert back to the original audience (instead of the api/v2). The api/v2 audience is likely the cause of the service not found and the login required errors. Once the original audience has been returned, please verify the API is registered within Auth0.

Feel free to direct message me or create a new if you have any questions on this front. Thanks!