Users in the database that were not created through Auth0 get blocked on login

I have a database with users that weren’t created through Auth0 and I would like to log those users in through Auth0 the problem is whenever the user logs in they get blocked in Auth0. When I use the login script for the database it works perfectly but if I make a login request to /oauth/token I get this returned Status 203 and the message "{\"error\":\"invalid_grant\",\"error_description\":\"user is blocked\"}". I have tried adding the connection, tenant and client_id to the entry in my database (because the ones created through Auth0 had them) and tried turning of brute force detection but neither of those things worked. Anyone have any ideas how to fix this issue?

As mentioned at (https://auth0.com/docs/connections/database/custom-db/error-handling#troubleshooting-errors) you can use console.log statements to troubleshoot custom database scripts alongside the Webtask Real-time Logs extension.

In this particular case it would be relevant to know the exact user profile that is returned as part of your login script. You can share it here after redacting/obscure the values of the properties. For example, it would be important to confirm if by any chance the profile returned contains a blocked property as that is used as means to block a user.

1 Like

You were right. I was able to fix it by removing a blocked field from my db. Thanks for your help.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.