Auth0 Home Blog Docs

Use Auth0 instead of IdP option disabled

auth0
sso
sso-integration
idp

#1

I have created a new client app and in the settings I have an option to enable/disable the IdP instead of Auth0, only problem is that the option itself is disable so it is always enabled and I can’t switch it off. So the question is: how do I switch it off?

![alt text][1]


#2

Same for me…


#3

Currently, new client applications created through the Dashboard will have the OIDC compliant toggle set in a way to ensure that they behave in accordance to the new OIDC and API Authorization flows. In this mode, which can also be described as not wanting to use the legacy flows, the Use Auth0 instead of the IdP to do Single Sign On option is always implicitly enabled so the Dashboard reflects that by disabling the ability to change it.


#4

Thanks. I was trying to debug a weird issue with why something was working locally and not on the dev machine, and this was just one of the things I noticed had been different… and had no idea if it mattered for my issue but it was just one of the things that was different.

aside - my issue was due to nginx silently removing my custom headers that had an underscore in their name (was not using nginx locally). Heads up if you’re using nginx because it’s a tricky one to track down!


#5

Thanks. I was trying to debug a weird issue with why something was working locally and not on the dev machine, and this was just one of the things I noticed had been different… and had no idea if it mattered for my issue but it was just one of the things that was different.

aside - my issue was due to nginx silently removing my custom headers that had an underscore in their name (was not using nginx locally). Heads up if you’re using nginx because it’s a tricky one to track down!


#6