Update Password for Users who Did Not Receive the the Password Reset Email

Overview

Some users are not receiving the Password Reset email. Thus, the affected users can not acquire the password update link. A tenant admin will need to provide the link manually.

Applies To

  • Password Reset
  • Password Reset Ticket

Cause

The email containing the password reset link is not available for certain users.

Solution

A password reset link can be created using the POST /api/v2/tickets/password-change endpoint in the Management API. Once the Bearer Token is set ("Set API Token " - in the up-right corner of the page), the “user_id” needs to be set in the body section. The Test Endpoint button will be accessed afterward. Once the command is run, it will create the reset link that can be passed to the affected user by any available but secure means.


NOTE: Each ticket can be used only once and needs to be created for each affected user. For more information about changing users’ passwords, please check the Auth0 documentation - Change Users’ Passwords.