Unable to Update Tenant Member Roles when All Roles are Deselected

Overview

This article explains an issue when trying to deselect all roles for a tenant member. Despite pressing the Update button, no changes seem to be made to the tenant’s settings.

Cause

Auth0 requires at least one active role for the tenant member.
If all roles are deselected, the Update button will not initiate any changes to the tenant settings.

Solution

In Auth0, if all roles are deselected for a tenant member and the Update button is clicked, the tenant’s settings will not be changed, and the Update button will have no effect.

This is because Auth0 requires a minimum of one active role for a tenant user in order for the update process to take effect.

Steps:

  1. Ensure that at least one active role is selected for the tenant member.
  2. Click the Update button.
  3. Verify that the changes have been saved.

If the intention is to remove all roles from a tenant member, the recommended action is to delete the tenant member entirely. This can be done through the Auth0 Dashboard by going to the Settings > Tenant Members selecting the relevant tenant member’s three dots on the right side, and then deleting the desired tenant member.

Please note the following points:

  • Only administrators have the necessary permissions to modify tenant member roles.
  • If the person who wants to make those changes is not an Admin, please contact an Admin within the Tenant to perform these actions.
  • Exercise caution when deleting a tenant member, as this action is irreversible and may affect other system processes that rely on this member.

In summary, if all roles are deselected for a tenant member, the Update button will not make any changes to the tenant’s settings. Removing all roles from a tenant member is recommended to delete the tenant member.