Unable to signup with an email address with an apostrophe

So we are able to login with a user with an apostrophe in the email address (using a 3rd party custom database).

However, when attempting to sign up with a user, we never even get to run the custom db scripts, the signup endpoint just returns this error:

{"message":"Invalid parameter value","fromSandbox":true,"statusCode":400}

I can’t seem to find where or how this is validated. We don’t have any custom rules or hooks.

EDIT: we are using classic universal login

Hi @jemdelcarmen,

Welcome to the Auth0 Community!

I understand that you have been experiencing issues with signing up with a custom database.

To help you better, could you please clarify if the issue happens after clicking the “sign up” button or does the login/signup page not load and return the error message?

Secondly, have you gotten a chance to use test the database scripts by pressing the Save and Try button?

This can happen when a function’s parameter gets assigned to a value that is not a member of the parameter’s defined set of acceptable values inside your database scripts.

With that, I recommend revising your database scripts again and testing them with the built-in “Save and Try” button. It may also be useful to include console.log() statements and debug with the Real-time Webtask Logs Extension.

I look forward to hearing from you.


Sorry I should have given examples.

So the signup functionality is already working. Tried and tested for months now.

The issue is with trying to signup with an email address with an apostrophe in it. Example: conano’brien@test.com

A lot of free email providers do not allow this character, but it is perfectly valid and should still be supported.

I have found the cause of the issue, it is part of the DB scripts that queries the 3rd party database.

I have solved this by enclosing the email address with double quotes (instead of single quotes) in the SQL query string.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.