Twitter Auth0 Intergration as described in tutorial not working


I followed this tutorial: How to Add a Twitter Social Connection in Auth0. When I tried the connection I get

  "error": "access_denied",
  "error_description": "InternalOAuthError: Could not authenticate you."

The twitter UI differs from the tutorial at enabling 3-legged OAuth, which is no longer an option. Also there is a choice of OAuth 2.0 and OAuth 1.0a, not in the video. I chose 1.0a.

Any suggestion are appreciated. Thanks

Hi there @sharonrlandis, welcome to the community!

Thanks for pointing this out - We try our best to keep everything up to date :confused:

I’ve attempted to enable this myself and am currently getting an error along the lines of:

  "error": "invalid_request",
  "error_description": "You currently have Essential access which includes access to Twitter API v2 endpoints only. If you need access to this endpoint, you’ll need to apply for Elevated access via the Developer Portal. You can learn more here:"

I imagine the solution here would be to make sure I have the “elevated” access mentioned in the error… What happens if you toggle the app you created in Twitter to use OAuth 2.0 instead?

Let us know!


OAuth2 gets the same result.

Your error message gives better direction than mine. Any suggestions to track down what this means-
“InternalOAuthError: Could not authenticate you.”

BTW, elevated access is “coming soon,” so not yet a solution. How do you suggest getting twitter sign in to work via Auth0?

Hi @sharonrlandis following up on this! Have you had any success since your last post?

I have not seen this error before personally, but the vast majority of time an error like this is due to a config related issue (typo, mismatch, etc.). Are you able to go back through on both the Auth0 and Twitter side to verify everything is correct? From within Auth0 and your Twitter connection there’s an option to test which you may find helpful in troubleshooting.

FWIW, I was able to apply for the elevated access and can confirm that after receiving said access the Twitter connection is functioning as expected. If the connection is successful when using the test option available in the connection itself, you should get redirected back to Auth0 and see a page like the following:

1 Like

I regenerated the keys and got the same error you did. An improvement! I’ll apply for elevated access and see what happens.

1 Like

Awesome! That’s good news - I received access almost immediately after applying and the error resolved the next login using the connection.

Let us know if the elevated access resolves the issue for you :smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.