Trying to login from WinForms application displays a blank window with "OK" on it

Hi Team,

I have a WinForms application developed on .NET Core 3.1 which uses Auth0.OidcClient.WinForms library. I was able to call LogoutAsync() successfully and LoginAsync() and get the whole authentication flow working. The issue is, suddenly I started getting the following blank window with an “OK” on it.

The only change I could think of was my network. I was on my home network when it was working for me, and today I tried with a different network (mobile hotspot).

Update: I tried from the home network and it still seems to be there.

However, everything else such as application code, Auth0 configuration remain the same.

What I have tried so far:

I right-clicked on the login window, and I can see that it’s not using MS Edge as I would have thought. It seems to be using IE11. So I removed IE11 from Windows. It still seems to be happening.

Here’s a screenshot of it:

I tried clearing my cache from Internet Properties/Temporary Internet Files etc. None of them seems to help. Does it fall back to IE11 for the webview when something’s not right?

I also found a workaround which is described as follows:

  1. When LoginAsync() is called it gives me the Auth0 login popup
  2. Upon successful, I get the blank window shown above.
  3. I could right click and hit “Back” option from the context menu
  4. Then, hit “Forward” button and the popup disappears, and I could use the application as usual.

Bit more info if it helps.
IDE: VS2019
OS: Windows 10 with latest updates (Windows 10 Pro - v2004)

I also came across this thread: I need to login from native Winforms desktop app without redirect to Auth0 Login Page

However, this seems to be happening for me on Windows 10. Let me know if I need to put more details to the question. Thanks!