Auth0 Home Blog Docs

Trying database connection

Hi,

I created a new database connection, nothing custom, just a basic database connection with email / password. Let’s call this database connection: DB-DEF.
I also created a user and added it to the DB-DEF connection. I also validated the user after it’s creation.
The problem is that when I try to test the connection I get a “Invalid username and / or password” message after submitting my credentials.
If I were to save the user into " Username-Password-Authentication" database and try the connection on this database, everything works fine.

Any idea why I cannot authenticate into DB-DEF with an active user?

Thank you

Hello @ciprian,

Have you enabled the DB-DEF database for the associated application?

Hey @markd,

Yes, it’s enabled, but I am trying to test the connection from Connections -> Database and then clicking the “Play” (Try) button. That leads me to the authentication form and tried with a newly created and activated user but it’s not working.

I tried this in one of my test tenants and it is working for me**. I think I am set up the same way you are, but there is obviously something different. Can you try logging in and then check the logs? The error message may be misleading or not exposing the actual error under the hood.

Also compare the raw JSON for the two users.

**new test tenant, added second DB connection + enabled for default app, created user ‘s1’ in default Username-Password-Authentication DB, created user ‘s2’ in second DB, clicked the “try” button for the second DB, tried logging in as ‘s1’ (fails), tried logging in as ‘s2’ (works).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.